Upload failures across Hudl products

Incident Report for Hudl

Resolved

After monitoring the fix we have put in place, Hudl Fan, Hudl Focus Uploads, Livestreaming and Hudl.com are back up and operational.
Posted Sep 04, 2026 - 18:52 CDT

Monitoring

Hudl Fan, Hudl Focus Uploads, Livestreaming and Hudl.com are all operational, and we are monitoring the fix we have put in place.
Posted Sep 04, 2026 - 18:22 CDT

Update

Hudl Fan, Livestreaming, and Hudl.com are all operational. We’re continuing to investigate issues with a small number of uploads from last night and working to get those fully resolved. We’ll share another update as we have more information.
Posted Sep 04, 2026 - 16:00 CDT

Update

We are continuing to investigate this issue.
Posted Sep 04, 2026 - 09:53 CDT

Investigating

We are currently investigating this issue.
Posted Sep 04, 2026 - 08:59 CDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Sep 04, 2026 - 02:22 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 21:40 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 21:15 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 21:02 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 20:39 CDT

Investigating

We are currently investigating the issue
Posted Sep 03, 2026 - 20:25 CDT
This incident affected: Hudl Fan (Hudl Fan, Hudl Livestreaming) and Hudl.com, Hudl Focus.