WIMU Cloud and WIMU Pro website is unreachable

Incident Report for Hudl

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 10:09 CST

Update

This incident has been resolved
Posted Nov 26, 2025 - 10:08 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 26, 2025 - 09:26 CST

Update

WimuPro is back up but it might be running in a degraded state
Posted Nov 26, 2025 - 09:25 CST

Investigating

We are currently investigating this issue.
Posted Nov 26, 2025 - 08:18 CST
This incident affected: Wimu.