Hudl Instat video is not loading

Incident Report for Hudl

Resolved

Hudl Instat Video player is back to 100% performance.

Teams should be able to play Hudl Instat without any issues. Still having trouble? Please try clearing your browser's cache and log back into Hudl Instat. Thanks again for your patience!
Posted Aug 12, 2025 - 13:59 CDT

Monitoring

A fix for the Instat Video player not loading for customers has been implemented.
Posted Aug 12, 2025 - 12:47 CDT

Update

We are continuing to investigate the Instat Video player not loading for customers.
Posted Aug 12, 2025 - 12:32 CDT

Update

We are continuing to investigate the Instat Video player not loading for customers.
Posted Aug 12, 2025 - 12:01 CDT

Update

We are continuing to investigate the Instat Video player not loading for customers.
Posted Aug 12, 2025 - 11:22 CDT

Update

We are continuing to investigate the Instat Video player not loading for customers.
Posted Aug 12, 2025 - 10:46 CDT

Investigating

We’re investigating issues with the Hudl Instat video player and will share an update shortly.
Posted Aug 12, 2025 - 10:12 CDT
This incident affected: Hudl Instat.