Support Help Form and Support Tutorials are down
Incident Report for Hudl
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 09:26 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2024 - 08:59 CDT
Investigating
The Support Help form and tutorial pages are currently down. We are investigating the issue.
Posted Oct 01, 2024 - 08:43 CDT
This incident affected: Hudl.com.