FastRecruit is not loading for users on Web or Mobile

Incident Report for Hudl

Resolved

FastRecruit is back to regular performance.

The root cause of the FastRecruit issue has been eliminated and your experience with FastRecruit should be a smooth one. We apologize for the disruption!
Posted May 15, 2026 - 19:18 CDT

Monitoring

We’ve applied a solution to FastRecruit, and the Schedules should now load.

We believe we've fixed the issue affecting FastRecruit Schedules. We’re monitoring the results of this solution and will let you know once we know more.

Schedule pages will take about a minute to initially load, but will return to normal behavior once loaded.

Thank you for sticking with us!
Posted May 15, 2026 - 18:09 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2026 - 17:35 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2026 - 17:00 CDT

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2026 - 16:38 CDT

Identified

The reason for FastRecruit failing to load has been identified, and we are working on a solution.

We’ve found the root cause of FastRecruit failing to load, and a solution to this problem is currently being implemented. Thanks for your patience. We’ll share an update as soon as things on FastRecruit are back up and running.
Posted May 15, 2026 - 16:04 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 15:38 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 15:02 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 14:31 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 14:00 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 13:17 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 12:46 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 12:11 CDT

Update

We are continuing to investigate this issue.
Posted May 15, 2026 - 11:19 CDT

Investigating

We are currently investigating this issues.
Posted May 15, 2026 - 10:42 CDT
This incident affected: FastModel.