Ticketing and Programs dashboards on Hudl.com are not loading correctly

Incident Report for Hudl

Resolved

This incident has been resolved.
Posted May 07, 2026 - 23:34 CDT

Investigating

We are currently investigating this issue.
Posted May 07, 2026 - 22:48 CDT
This incident affected: Hudl.com and Hudl Fan (Hudl Tickets).