Partial Service Disruption: Missing Player Data on Instat Profiles

Incident Report for Hudl

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 17:49 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 02, 2026 - 16:28 CST

Update

Player Profile Data Issues: We are currently investigating a technical issue affecting the display of player names, photos, and career statistics for certain teams. While our team works on a resolution, match-level statistics and game film remain fully accessible through the "Games" tab.
Posted Feb 02, 2026 - 15:06 CST

Investigating

A technical issue is currently impacting the display of player names, photos, and statistics for certain rosters. All game film and match-level data remain accessible as this is investigated.
Posted Feb 02, 2026 - 12:55 CST
This incident affected: Hudl Instat.