We are experiencing issues with Balltime users loading their Library, Reports, Highlights and Scouting pages

Incident Report for Hudl

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 22:29 CST

Monitoring

A fix has been implemented and we are monitoring results
Posted Feb 23, 2026 - 22:10 CST

Investigating

We are currently investigating the issue
Posted Feb 23, 2026 - 20:19 CST
This incident affected: Balltime.