Hudl.com is experiencing delays in performance.

Incident Report for Hudl

Resolved

Hudl.com workflows are back online, with video processing delays now all caught up. The Volleymetrics site is up, as is vCloud. We worked through checks, over-scaled our systems and fixed some issues that were caused by the AWS outage, and we’re confident that the incident is resolved.
Posted Oct 20, 2025 - 17:00 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 15:49 CDT

Update

We are continuing to investigate the issues and will continue to update this page as we hear more from our team.
Posted Oct 20, 2025 - 14:58 CDT

Update

We are continuing to investigate the issues and will continue to update this page as we hear more from our team.
Posted Oct 20, 2025 - 13:56 CDT

Update

We’ve identified the cause of the delays in performance and are working towards a solution.
Posted Oct 20, 2025 - 12:52 CDT

Update

We’ve identified the cause of the delays in performance and are working towards a solution.
Posted Oct 20, 2025 - 12:05 CDT

Identified

We’ve identified the cause of the delays in performance and are working towards a solution.
Posted Oct 20, 2025 - 11:31 CDT

Update

We are continuing to investigate the issues and will continue to update this page as we hear more from our team.
Posted Oct 20, 2025 - 10:33 CDT

Update

We are continuing to investigate the issues and will continue to update this page as we hear more from our team.
Posted Oct 20, 2025 - 10:22 CDT

Investigating

Hudl is experiencing some delays in page loading, password resets and video uploads. If you are experiencing issues please reach out at hudl.com/help
Posted Oct 20, 2025 - 09:45 CDT
This incident affected: Hudl Fan (Hudl Fan, Hudl Tickets, Hudl Livestreaming) and Hudl.com, Hudl Focus, Volleymetrics, Wyscout, Hudl Instat.